While I am installing Oracle 11.2.0.4 on RHEL 7.6 I hit this message on prereq screen.

After I made some search I found a solution as below.

Login as installation user. In my case my user is oracle

A. Check  ksh package then ignore the warning and proceed with the installation

As root user:

 

[root@veridata ~] yum install ksh

If the package already installed You will hit below message

[root@veridata ~]# yum install ksh -y
Loaded plugins: langpacks, ulninfo
Package ksh-20120801-139.0.1.el7.x86_64 already installed and the latest version.Nothing to do

B. Edit below file and restart installation from beginning.

[oracle@veridata ~]# cd /YOUR_SETUP_PATH_HERE/database/stage/cvu/cv/admin

# Fallback to this distribution id
CV_ASSUME_DISTID=OEL4

to

# Fallback to this distribution id
CV_ASSUME_DISTID=OEL6

D. If you have still same problem start installation as 

[oracle@veridata ~]# ./runInstaller -ignorePrereq

 

Reference:Missing pdksh-5.2.14 package during Oracle database 11.2.0.4 install on Oracle Linux 7 (Doc ID 1962046.1)

Advertisements